Back to overview
Downtime

Power outage

Mar 8, 2023 at 9:50pm UTC
Affected services
Website
Plex
Ombi

Resolved
Mar 9, 2023 at 12:34am UTC

Services are back to normal.

Created
Mar 8, 2023 at 9:50pm UTC

Will update with ETA as more information is provided.