Back to overview
Downtime
Network outage
Dec 16 at 12:22am EST
Affected services
Website
Plex
Ombi
Resolved
Dec 16 at 01:00am EST
Service are back up.
Affected services
Created
Dec 16 at 12:22am EST
We are experiencing a networking outage. Services are unavailable at this time.
Affected services